tommymac

Members
  • Content count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tommymac

  • Rank
    Newbie
  • Birthday 01/01/1970

Profile Information

  • Gender
    Male
  1. stumped

    rebuilt my 660 top and bottom everything is stock other than 101mm bore and piston, and new crank rod and piston, rebuild went fine everything out of the clymer book was straightforward, but now I'm starting it for the first time(trying) and something's not right, without the plug in it turns over fine sounds good, with the plug in tho I can only turn it over a few times and it seems to lock up, swear I had the timing right but I'll go over everything before I have to tear it back down.. anyone got a hunch Sent from my iPhone using Tapatalk
  2. blew er up

    headin to the garage now... my first thought was to hit it through the valve cover... that's what I'm going to do Sent from my iPhone using Tapatalk
  3. blew er up

    oh yea but I came here to ask, I had just finished the top and bottom end rebuild tonight around 8-9 and don't live far from people at all so I was only able to crank it a few times but I wasn't able to get the oil to capacity, spec says 2.3 I believe but I got about 1.75 in the tank, how do i go about starting it first should I put some oil down the spark plug hole so it doesn't get dry or just go for it Sent from my iPhone using Tapatalk
  4. blew er up

    got an 01 I bought not running, rebuilt the carb and unplugged the parking brake switch fired up great, changed the oil filter, air filter and do the valves,.. all at once, and appearantly, maybe not but most likely finger tightend the oil drain plug, went to grab the ratchet and forgot what I was looking for and continued on to something else... well the day I get out of work in a snow storm(first ride running good) I hop on the betch and do some high speed drifting in the snow in a pack of 6 quads, mostly 400s with mods, bike shut off on me a few times in the last 2 hours of the 5 hours we were out, I of course started back up and hurried to catch up, the last time it shut off I heard it go, Sent from my iPhone using Tapatalk